Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FAQ EDC Pumps / W202/W210 W463 ECU’s
baldur Online
Fast
****


Posts: 386
Joined: Dec 2013
Location: Iceland
#51
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
(02-01-2018, 02:53 AM)Mr.Emo Wrote: Yes. I was talking about the thing you solder into the ecu and reprogram the ews module.

But I was wondering about the egr, maf etc if they will work in standalone car with just the ews removed. Smile

Yes that will work.
Baldur Gislason

02-01-2018, 05:33 AM
Website Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#52
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Thanks Baldur. I just need to get my car approved with everything original before I'm able to use your ecu. Smile
02-01-2018, 06:19 AM
Find Reply
AlanMcR Offline
mind - blown
****


Posts: 296
Joined: May 2009
Location: USA
#53
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
The EGR and MAF are directly wired into the ECU, so they will come as part of the wiring package. They will work.
02-01-2018, 09:54 AM
Find Reply
starynovy Offline
Holset
****


Posts: 323
Joined: Sep 2014
Location: Central Europe
#54
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Have anyone figured out which code block is used? Pretty anoying to do every change 8 times. Big Grin
-------------------------------------------------------------------------------------------------------------------------
Ex: 525tds 130kW, C250TD 160kW, E320CDI 200kW, ML400CDI 230kW, A6 R5TDI 130kW
Now: Q7 V8TDI 240kW, 320d 150kW, 335d 210kW
02-09-2018, 02:02 PM
Find Reply
oleg213 Offline
Naturally-aspirated
*


Posts: 19
Joined: Mar 2013
Location: Minsk, Republic of Belarus
#55
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
(02-09-2018, 02:02 PM)starynovy Wrote: Have anyone figured out which code block is used? Pretty anoying to do every change 8 times. Big Grin
 the system checks the checksum, accordingly all 8 blocks must match
like only 5 and 6 blocks have differences
02-10-2018, 01:38 PM
Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#56
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Is there an alternative glow plug relay one can use? Or is the oem only way to go? Seeing the output says (k-line).
03-12-2018, 02:03 PM
Find Reply
oleg213 Offline
Naturally-aspirated
*


Posts: 19
Joined: Mar 2013
Location: Minsk, Republic of Belarus
#57
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
W124 relay works standalone
03-13-2018, 05:27 AM
Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#58
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Hmm. Then I would also need the wiring. I have from w210 but I forgot to take out the glow plug relay. That's why I'm asking if the signal from the ecu is just a 12v signal so I can use whichever relay I desire or not. Smile
03-13-2018, 12:13 PM
Find Reply
AlanMcR Offline
mind - blown
****


Posts: 296
Joined: May 2009
Location: USA
#59
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
The W210 glow plug relay is controlled by something more complex than a simple 12V "go" signal. Some friends tried to get one to work without the ECU and didn't have any luck at all. The relay also passes data back to the ECU indicating success/failure of the glow cycle. If you are using the W210 instrument cluster, it will report glow plug issues recorded by the ECU.
03-13-2018, 01:06 PM
Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#60
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
The engine is going into a patrol so that's not going to happen. I guess I will have to make a solution myself then.
03-13-2018, 02:35 PM
Find Reply
oleg213 Offline
Naturally-aspirated
*


Posts: 19
Joined: Mar 2013
Location: Minsk, Republic of Belarus
#61
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
[Image: 76141d1263185263-diagnosing-glow-control...-23.46.jpg]
50- start signal
31- ground
15- ignition sw on
LA- signal lamp
T- engine temperature sensor
30- +12v terminal 
61-66 - glow plugs
03-13-2018, 03:09 PM
Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#62
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Anyone that know what the signal to 80 Air Conditioning on the schematics looks like? Is it a signal that tells the ECU that the AC compressor is running? Any help greatly appreciated. Smile
06-11-2018, 01:14 PM
Find Reply
AlanMcR Offline
mind - blown
****


Posts: 296
Joined: May 2009
Location: USA
#63
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Is the number 80 a pin number or a circuit number? As far as I can tell there is no connection between the AC and the ECU on the OM606.964. The built-in idle stabilization handles the extra load of the AC compressor all by itself.
06-12-2018, 09:55 AM
Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#64
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
It's the item number in the first post and uses pin 16 on the ecu. I've got no clue tried looking in the workshop manual. But it's really hard to find anything in there.
06-12-2018, 03:06 PM
Find Reply
AlanMcR Offline
mind - blown
****


Posts: 296
Joined: May 2009
Location: USA
#65
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
I see. Pin 16 is unused on the G300 (1996->2000). The wiring diagram for the 1997 E300 (non-turbo) shows the pin as unused too.
06-12-2018, 03:35 PM
Find Reply
Mr.Emo Offline
Nissan Patrol -> 606 conversion.
**


Posts: 69
Joined: Jul 2017
Location: Norway
#66
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
My engine comes from a 98 w210 with turbo. And I've got a wire comming out of pin 16. Guess I have to do some more research. Smile
06-13-2018, 12:33 AM
Find Reply
AlanMcR Offline
mind - blown
****


Posts: 296
Joined: May 2009
Location: USA
#67
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Please do. It would be good to know where it goes, what the signal is, and what the ECU actually does differently when it gets the signal.
06-14-2018, 01:53 PM
Find Reply
starynovy Offline
Holset
****


Posts: 323
Joined: Sep 2014
Location: Central Europe
#68
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Wiring ´87 W124 with 605 turbo and ECU. My doubt is about ECU being from an automatic trans car. Will it start without EGS? Or alternatively if I programmed EPROMs with dump from manual will it run? Asking for experiences because it is hard to troubleshoot something which cannot be diagnosed and may not run for several reasons at once. Big Grin Also I dumped ELAB, I suppose it is enough to disable DTC code for it to start?
-------------------------------------------------------------------------------------------------------------------------
Ex: 525tds 130kW, C250TD 160kW, E320CDI 200kW, ML400CDI 230kW, A6 R5TDI 130kW
Now: Q7 V8TDI 240kW, 320d 150kW, 335d 210kW
04-07-2019, 03:38 AM
Find Reply
whipplem104 Offline
Holset
****


Posts: 558
Joined: Oct 2011
Location: Seattle, Wa
#69
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
I do not know about the 605 but here in the U.S. The 606 ecu had a ground signal for N/S from the TCU. I assume it is the same as a manual trans input. I never knew this until a year ago. Also same era gas cars. m120, m119, m104. Me 2.0 This is all it needs to start.
04-07-2019, 10:45 AM
Find Reply
seanyt Offline
is300d He351ve
****


Posts: 279
Joined: May 2014
Location: Ireland
#70
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
I have used many types of ecus automatic and manual om605 and they all work fine without egs ecu. 
once youve got the cr1 immobiliser fitted and immo chip programmed no reason it should'nt start and run once turned over.
04-08-2019, 08:32 AM
Find Reply
starynovy Offline
Holset
****


Posts: 323
Joined: Sep 2014
Location: Central Europe
#71
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Yeah, wired it, put fuel in and it starts but there is a problem.. Big Grin It races with RPMs I dont know where, shut it off at 3000. Rack is not stuck, moves freely, doing it with TPS disconnected too. Ehm what the phuck. Havent tinkered with EPROMs yet so it should idle fine and be in limp-EGR and ELAB disconnected.
-------------------------------------------------------------------------------------------------------------------------
Ex: 525tds 130kW, C250TD 160kW, E320CDI 200kW, ML400CDI 230kW, A6 R5TDI 130kW
Now: Q7 V8TDI 240kW, 320d 150kW, 335d 210kW
04-10-2019, 09:04 AM
Find Reply
INC Offline
GTA2056V
**


Posts: 75
Joined: Oct 2009
Location: Latvia
#72
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
(04-10-2019, 09:04 AM)starynovy Wrote: Yeah, wired it, put fuel in and it starts but there is a problem.. Big Grin It races with RPMs I dont know where, shut it off at 3000. Rack is not stuck, moves freely, doing it with TPS disconnected too. Ehm what the phuck. Havent tinkered with EPROMs yet so it should idle fine and be in limp-EGR and ELAB disconnected.

Thats a way how ecu test ELAB and know that You remove it Smile
When You shut down engine ECU move rack to add fuel, and close ELAB  in same time, if there is jump in rpm
fault code is set, and second derrate limiter is active.
G300TD(OM606.964) & 250GD(OM605.960)Trophy raid
04-11-2019, 01:01 PM
Find Reply
AlanMcR Offline
mind - blown
****


Posts: 296
Joined: May 2009
Location: USA
#73
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
(04-11-2019, 01:01 PM)INC Wrote:
(04-10-2019, 09:04 AM)starynovy Wrote: Yeah, wired it, put fuel in and it starts but there is a problem.. Big Grin It races with RPMs I dont know where, shut it off at 3000. Rack is not stuck, moves freely, doing it with TPS disconnected too. Ehm what the phuck. Havent tinkered with EPROMs yet so it should idle fine and be in limp-EGR and ELAB disconnected.

Thats a way how ecu test ELAB and know that You remove it Smile
When You shut down engine ECU move rack to add fuel, and close ELAB  in same time, if there is jump in rpm
fault code is set, and second derrate limiter is active.
Not sure what you were trying to say here, but it sounds interesting. Can you give another try at explaining what you meant?
04-12-2019, 05:50 PM
Find Reply
seanyt Offline
is300d He351ve
****


Posts: 279
Joined: May 2014
Location: Ireland
#74
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Never seen an engine start and the revs just go up. Especially with a stock ECU. Doesn't sound like a failsafe mode either.

Have you chopped up the wiring loom. I always advise people to not alter the pump wiring. Is this an msa25 ECU or older style?
04-13-2019, 02:45 AM
Find Reply
starynovy Offline
Holset
****


Posts: 323
Joined: Sep 2014
Location: Central Europe
#75
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
Sorted.. idiots put flywheel from 2.5 diesel as per request.. just did not confess about small detail of being from W124 without 5 engine speed teeth. Big Grin It somehow picks up magnetic field of some sort so it starts fuel delivery but never picks up correct RPMs so it stays in start position, would run away to destruction.

About the loom, made it from scratch. Most of the wires were in sorry state and too long-ECU moved to LHD side. Shortened both pump and VR sensor shielded wires. Nothing is lengthened, proper crimping at ECU connector with new pins.
-------------------------------------------------------------------------------------------------------------------------
Ex: 525tds 130kW, C250TD 160kW, E320CDI 200kW, ML400CDI 230kW, A6 R5TDI 130kW
Now: Q7 V8TDI 240kW, 320d 150kW, 335d 210kW
04-14-2019, 06:32 AM
Find Reply
starynovy Offline
Holset
****


Posts: 323
Joined: Sep 2014
Location: Central Europe
#76
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
If they tuned something they did main maps, just open any MSA25 hexdump, find those maps (list is even there on first page) and copy them. You dont need exact SW version for this.
-------------------------------------------------------------------------------------------------------------------------
Ex: 525tds 130kW, C250TD 160kW, E320CDI 200kW, ML400CDI 230kW, A6 R5TDI 130kW
Now: Q7 V8TDI 240kW, 320d 150kW, 335d 210kW
04-24-2019, 04:43 AM
Find Reply
starynovy Offline
Holset
****


Posts: 323
Joined: Sep 2014
Location: Central Europe
#77
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
So it is finished, but man it gave some headaches. In the end I had to remove this pile of errors P1622, P1407, P1402, P1223, P1482, P1221, P0600 from which P1223 came out of nowhere after day of flawless running.. something related to pump itself, never seen it.



-------------------------------------------------------------------------------------------------------------------------
Ex: 525tds 130kW, C250TD 160kW, E320CDI 200kW, ML400CDI 230kW, A6 R5TDI 130kW
Now: Q7 V8TDI 240kW, 320d 150kW, 335d 210kW
04-29-2019, 04:12 AM
Find Reply
junkyarddawg Offline
Naturally-aspirated
*


Posts: 7
Joined: Feb 2019
Location: USA
#78
RE: FAQ EDC Pumps / W202/W210 W463 ECU’s
(04-29-2019, 04:12 AM)starynovy Wrote: So it is finished, but man it gave some headaches. In the end I had to remove this pile of errors P1622, P1407, P1402, P1223, P1482, P1221, P0600 from which P1223 came out of nowhere after day of flawless running.. something related to pump itself, never seen it.




Nice engineering work !
Will be great fun and daily driver... enjoy
04-29-2019, 07:14 PM
Find Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)